Advertise on DISCO4.COM
Forum · Gallery · Wiki · Shop · Sponsors
DISCO4.COM > In Car Electronics (D4)

D4 Infotainment gremlins - Help!!!
Post Reply  Down to end
Page 2 of 2 <12
M3bobby
 


Member Since: 21 May 2018
Location: Sleaford, LINCS.
Posts: 408

United Kingdom 

Acc or accessories, used to be when you put your key in the ignition and turned it to get the radio etc on without starting the engine. So for us, it would be pressing the start button without placing your foot on the brake allowing the accessories to come on without the engine.
  
Post #206850815th Jul 2019 6:32 pm
View user's profile Send private message View poster's gallery Reply with quote
sarahhowen01
 


Member Since: 16 Aug 2012
Location: Cheshire
Posts: 59

United Kingdom 2011 Discovery 4 3.0 SDV6 HSE Lux Auto Stornoway GreyDiscovery 4

Thanks for that, yes it still faults when in acc mode Sad
  
Post #206851015th Jul 2019 6:42 pm
View user's profile Send private message View poster's gallery Reply with quote
M3bobby
 


Member Since: 21 May 2018
Location: Sleaford, LINCS.
Posts: 408

United Kingdom 

For some reason I had it in my head your car was a 2011 registered 12 model year but I’m thinking I’ve assumed that and your car is actually a 2011 model year. Is that correct?

Is the fault happening every time now or is it intermittent?

If/when it faults, if you lock the car and leave it for 10 mins before opening up again, can it appear to reset? But then fault again soon after?
  
Post #206851815th Jul 2019 7:22 pm
View user's profile Send private message View poster's gallery Reply with quote
keithhibbert
 


Member Since: 14 May 2019
Location: Londonderry
Posts: 9

Northern Ireland 2010 Discovery 4 3.0 TDV6 XS Auto Santorini BlackDiscovery 4

Have a similar problem. Everything works fine while ignition is on but in less than a minute is starting the engine it cuts in and out, sometimes freezes, sometimes blanks out some of the audio options, sometimes it boasts out static that the volume control did nothing for! I have an icarsoft lr11 and it's showing no codes. My mechanic contacted an independent who contacted a company they use for all electronic problems and they say that it's a common fault, something to do with the circuit board that needs fixing. The head unit can be sent to them for repair. I'm told back in 3 days.

Not sure of cost as mines being done under warranty.
  
Post #206856615th Jul 2019 9:38 pm
View user's profile Send private message View poster's gallery Reply with quote
M3bobby
 


Member Since: 21 May 2018
Location: Sleaford, LINCS.
Posts: 408

United Kingdom 

So ignoring the DAB DTCs we have

U3000-04Control Module - System Internal Failures Audio unit internal failure - no communications with
CD module Check the power and ground circuits to the component. Refer to the electrical circuit diagrams.

U3000-4AControl Module - incorrect component installed Digital audio broadcast module incorrect
component installed. The module has been installed to a vehicle not configured to accept it
Using the manufacturer approved diagnostic system select the vehicle configuration main menu, select configure existing modules menu and program the module.

U3000-55Control Module - not configured Digital audio broadcast module not configured correctly
Using the manufacturer approved diagnostic system select the vehicle configuration main menu, select configure existing modules menu and program the module.

U3000-87Control Module - missing message Missing message Using the manufacturer approved diagnostic system select the vehicle configuration main menu, select configure existing modules menu and program the module.

U3000-98Control Module - component or system over temperature Digital audio broadcast module component or system over temperature Cool the vehicle interior down by ensuring it is in the shade
and have the A/C on cool. When cool, clear the DTC and retest. If the problem persists, renew the module.

It looks like your DAB module has been replaced with an incompatible unit in the past so a correctly configured module could fix those related DTCs.

The only one not attributable to the DAB is U3000-04 which suggests its the CD unit, I'm not sure what Model year you have or what level of infotainment you have but I would be checking continuity on the CD unit and if it's available on the CAN. If everything checks out I'd then be looking at a replacement unit from a reputable breaker (with warranty) and I'd also look for a good DAB unit suitable for your vehicle.

Can you PM me your VIN and I'll look at what part numbers you would need.
  
Post #206856915th Jul 2019 9:51 pm
View user's profile Send private message View poster's gallery Reply with quote
sarahhowen01
 


Member Since: 16 Aug 2012
Location: Cheshire
Posts: 59

United Kingdom 2011 Discovery 4 3.0 SDV6 HSE Lux Auto Stornoway GreyDiscovery 4

Hi, Thanks for all that m3bobby - i'll PM you the VIN number in a second............ Very Happy

Re the DAB module, i'd be very surprised if its been changed, Im the second owner and the first owner did very little mileage in the car and had it religiously maintained at the main dealers (and was a slightly more mature gentleman should we say) Could it be that the module has just failed and thats causing the issues??

Are the DAB modules easy to replace and are they expensive? its not been a major issue to not have it but if its a quick and easy fix then why not!!

I actually thought it had resolved it earlier as I did about 30 miles (Majority towing) and it didnt do it once but now its back although not as bad as before..........

I can live with the issue in the short term but it has been suggested to me that it could lead onto more issues with the car electronics - is the control module that affected restricted to the infotainment system or does it control the whole car???

Thanks again for all your help guys - its seriously appreciated Smile
  
Post #206877816th Jul 2019 7:12 pm
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 2 of 2 <12
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO4.COM Copyright © 2004-2019 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO4.COM is independent and not affiliated to Land Rover.
Switch to Mobile Site