Advertise on DISCO4.COM
Forum · Gallery · Wiki · Shop · Sponsors
DISCO4.COM > In Car Electronics (D4)

DVD Player Not Working - Fix / Modify?
Post Reply  Down to end
Page 1 of 1
Villager
 


Member Since: 05 Jan 2018
Location: Southampton
Posts: 82

United Kingdom 2010 Discovery 4 3.0 TDV6 HSE Auto Stornoway GreyDiscovery 4
DVD Player Not Working - Fix / Modify?

Hi all, hoping someone can help.

The car has stopped loading DVDs. When I select DVD on the screen, either some or none of the loaded DVDs will illuminate as being present, but when selected, nothing happens.

Anyone know what the issue is likely to be?

Alternatively, is it possible to input films/video files in a different way?
  
Post #20655732nd Jul 2019 1:32 pm
View user's profile Send private message View poster's gallery Reply with quote
Villager
 


Member Since: 05 Jan 2018
Location: Southampton
Posts: 82

United Kingdom 2010 Discovery 4 3.0 TDV6 HSE Auto Stornoway GreyDiscovery 4

Anyone she'd any light on this for me?
  
Post #211716430th Jan 2020 8:52 pm
View user's profile Send private message View poster's gallery Reply with quote
M3bobby
 


Member Since: 21 May 2018
Location: Sleaford, LINCS.
Posts: 679

United Kingdom 

Not sure I follow, have you a separate DVD player? The head unit can only take one DVD at a time.
 012MY RRS 5.0 Supercharged Autobiography (Current)
Mods:
TPMS (Complete but got an issue)
Genuine LR DRLs (Complete)
Remote Boot close from key fob (Complete)
2016 Discovery 4 Mirrors AKA RRS2 (Complete)
2014 L405 Surround Camera retro fit (Now 2016 L319)
2013 RRS Dual View Screen fit (Complete)
2016 LR4 RSE (Complete)
2014 LR4 Homelink (Complete)
2016 FFRR Electrochromatic Wing Mirror Glass (Complete) 
 
Post #211728931st Jan 2020 9:59 am
View user's profile Send private message View poster's gallery Reply with quote
Villager
 


Member Since: 05 Jan 2018
Location: Southampton
Posts: 82

United Kingdom 2010 Discovery 4 3.0 TDV6 HSE Auto Stornoway GreyDiscovery 4

Yeah there's a multichanger in the boot
  
Post #211729231st Jan 2020 10:12 am
View user's profile Send private message View poster's gallery Reply with quote
M3bobby
 


Member Since: 21 May 2018
Location: Sleaford, LINCS.
Posts: 679

United Kingdom 

What year car is it? It sounds like your multi changer may be the issue.
 012MY RRS 5.0 Supercharged Autobiography (Current)
Mods:
TPMS (Complete but got an issue)
Genuine LR DRLs (Complete)
Remote Boot close from key fob (Complete)
2016 Discovery 4 Mirrors AKA RRS2 (Complete)
2014 L405 Surround Camera retro fit (Now 2016 L319)
2013 RRS Dual View Screen fit (Complete)
2016 LR4 RSE (Complete)
2014 LR4 Homelink (Complete)
2016 FFRR Electrochromatic Wing Mirror Glass (Complete) 
 
Post #21175531st Feb 2020 11:09 am
View user's profile Send private message View poster's gallery Reply with quote
Villager
 


Member Since: 05 Jan 2018
Location: Southampton
Posts: 82

United Kingdom 2010 Discovery 4 3.0 TDV6 HSE Auto Stornoway GreyDiscovery 4

It's a 2010 car. Anyone know he part number for the multichanger?
  
Post #21175561st Feb 2020 11:25 am
View user's profile Send private message View poster's gallery Reply with quote
dewillia
 


Member Since: 04 Aug 2019
Location: Wolverhampton
Posts: 47

United Kingdom 2011 Discovery 4 3.0 SDV6 HSE Auto Stornoway GreyDiscovery 4

It will be stamped on the one you have, you might as well pull it out anyway and check all connections etc
  
Post #21175921st Feb 2020 1:13 pm
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO4.COM Copyright © 2004-2020 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO4.COM is independent and not affiliated to Land Rover.
Switch to Mobile Site