Advertise on DISCO4.COM
Forum · Gallery · Wiki · Shop · Sponsors
DISCO4.COM > Technical (D3)

Throttle Pedel fault
Post Reply  Down to end
Page 1 of 1
Gid
 


Member Since: 22 Sep 2013
Location: Southampton
Posts: 18

United Kingdom 2006 Discovery 3 TDV6 HSE Auto Zambezi SilverDiscovery 3
Throttle Pedel fault

Hi All
My 2006 HSE Discovery 3 has gone into limp mode with Engine management warning on dash.
Garage plugged it in and read the faults it said Throttle Pedel sensor problem. This was replaced with a genuine landrover one 6 weeks ago, so am a little miffed that it has gone again so soon.

Has anyone had a similar problem or know if this is a common problem or could it be something else causing it to go? please let me know

thanks Gid.
  
Post #20982187th Nov 2019 8:02 pm
View user's profile Send private message View poster's gallery Reply with quote
Globetrotter448
 


Member Since: 21 Mar 2017
Location: Londonderry NSW
Posts: 847

Australia 2007 Discovery 3 4.0 V6 Petrol SE Auto Java BlackDiscovery 3

Might just be the connector on the throttle pedal module
  
Post #20982788th Nov 2019 7:18 am
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO4.COM Copyright © 2004-2019 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO4.COM is independent and not affiliated to Land Rover.
Switch to Mobile Site